Monday, July 13, 2009

Implementing IPv6 Tunneling over IPv4 using Manual Tunnel Lab


Configuration Guidelines::
PE-CE Routing Used "Static"
IGP Used "ISIS" Level 2 between PE1 ,P1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
IPv6 Tunnel established between PE1 & PE2 over Tunnel Interface 10
********************************************************************************

CE1A#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:5::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::2/64
!
ipv6 route ::/0 FastEthernet1/0 2001:810:FFFF:1::1
ipv6 route ::/0 FastEthernet1/0
!

CE1A#




PE1#sh running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Tunnel10
description <>
ipv6 address 2001:0DB8:1111:2222::1/64

tunnel source loopback 0

tunnel destination 10.0.3.1

tunnel mode ipv6ip

!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::1/64
!
interface FastEthernet1/1
description <>
ip address 192.168.1.1 255.255.255.252
duplex full
speed 100
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.2222.3333.00
redistribute connected route-map Only_Local
!
ipv6 route FEC0:0:0:5::1/128 FastEthernet1/0 2001:810:FFFF:1::2
ipv6 route 2001:1210:FFFF:1::/64 Tunnel 10
ipv6 route FEC0:0:0:4::1/128 Tunnel 10

!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/0
!
PE1#




P1#sh running-config
ip cef
!
!
!
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1

!

interface FastEthernet1/0
description <>
duplex full
speed 100
ip address 192.168.1.2 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
duplex full
speed 100
ip address 192.168.1.5 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.1111.2222.00
!

P1#


PE2#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
interface Tunnel10
description <>
ipv6 address 2001:0DB8:1111:2222::2/64
tunnel source loopback 0

tunnel destination 10.0.1.1

tunnel mode ipv6ip

!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
!
interface FastEthernet1/0
description <>
duplex full
speed 100
ip address 192.168.1.6 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::1/64
!
router isis
net 49.0002.2222.1111.3333.00
redistribute connected route-map Only_Local
!
ipv6 route FEC0:0:0:4::1/128 FastEthernet1/1 2001:1210:FFFF:1::2
ipv6 route 2001:810:FFFF:1::/64 Tunnel 10
ipv6 route FEC0:0:0:5::1/128 Tunnel 10
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/1
!

PE2#




CE2A#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:4::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::2/64
!

ipv6 route ::/0 FastEthernet1/0 2001:1210:FFFF:1::1
ipv6 route ::/0 FastEthernet1/0
!
CE2A#



OUTPUT VERIFICATION

CE1A#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C801:BFF:FE44:1C
2001:810:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C801:BFF:FE44:0
FEC0:0:0:5::1




CE1A#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via 2001:810:FFFF:1::1, FastEthernet1/0
via ::, FastEthernet1/0
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:5::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE1A#

CE1A#ping ipv6 FEC0:0:0:4::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:4::1, timeout is 2 seconds:
.!...
Success rate is 20 percent (1/5), round-trip min/avg/max = 88/88/88 ms
CE1A#


PE1#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C802:BFF:FE44:1C
2001:810:FFFF:1::1
FastEthernet1/1 [up/up]
Loopback0 [up/up]
Tunnel10 [up/up]
FE80::C802:BFF:FE44:0
2001:DB8:1111:2222::1


PE1#show ipv6 route
IPv6 Routing Table - 8 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/0
C 2001:DB8:1111:2222::/64 [0/0]
via ::, Tunnel10
L 2001:DB8:1111:2222::1/128 [0/0]
via ::, Tunnel10
S 2001:1210:FFFF:1::/64 [1/0]
via ::, Tunnel10
S FEC0:0:0:4::1/128 [1/0]
via ::, Tunnel10
S FEC0:0:0:5::1/128 [1/0]
via 2001:810:FFFF:1::2, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0


PE1#show interfaces tunnel 10
Tunnel10 is up, line protocol is up
Hardware is Tunnel
Description: <>
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 10.0.1.1 (Loopback0), destination 10.0.3.1
Tunnel protocol/transport IPv6/IP
Tunnel TTL 255
Fast tunneling enabled
Tunnel transmit bandwidth 8000 (kbps)
Tunnel receive bandwidth 8000 (kbps)
Last input 00:02:35, output 00:05:42, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
13 packets input, 1464 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
14 packets output, 1356 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
PE1#

PE1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/32 is subnetted, 3 subnets
i L2 10.0.3.1 [115/20] via 192.168.1.2, FastEthernet1/1
i L2 10.0.2.1 [115/20] via 192.168.1.2, FastEthernet1/1
C 10.0.1.1 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.0 is directly connected, FastEthernet1/1
i L2 192.168.1.4 [115/20] via 192.168.1.2, FastEthernet1/1
PE1#

P1#show isis neighbors

System Id Type Interface IP Address State Holdtime Circuit Id
PE2 L2 Fa1/1 192.168.1.6 UP 7 PE2.01
PE1 L2 Fa1/0 192.168.1.1 UP 28 P1.02




P1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/32 is subnetted, 3 subnets
i L2 10.0.3.1 [115/10] via 192.168.1.6, FastEthernet1/1
C 10.0.2.1 is directly connected, Loopback0
i L2 10.0.1.1 [115/10] via 192.168.1.1, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.0 is directly connected, FastEthernet1/0
C 192.168.1.4 is directly connected, FastEthernet1/1
P1#





PE2#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FastEthernet1/1 [up/up]
FE80::C804:9FF:FED4:1D
2001:1210:FFFF:1::1
Loopback0 [up/up]
Tunnel10 [up/up]
FE80::C804:9FF:FED4:0
2001:DB8:1111:2222::2


PE2#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S 2001:810:FFFF:1::/64 [1/0]
via ::, Tunnel10
C 2001:DB8:1111:2222::/64 [0/0]
via ::, Tunnel10
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/1
L 2001:1210:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/1
S FEC0:0:0:4::1/128 [1/0]
via 2001:1210:FFFF:1::2, FastEthernet1/1
S FEC0:0:0:5::1/128 [1/0]
via ::, Tunnel10
L FF00::/8 [0/0]
via ::, Null0


PE2#show interfaces tunnel 10
Tunnel10 is up, line protocol is up
Hardware is Tunnel
Description: <>
MTU 1514 bytes, BW 9 Kbit, DLY 500000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation TUNNEL, loopback not set
Keepalive not set
Tunnel source 10.0.3.1 (Loopback0), destination 10.0.1.1
Tunnel protocol/transport IPv6/IP
Tunnel TTL 255
Fast tunneling enabled
Tunnel transmit bandwidth 8000 (kbps)
Tunnel receive bandwidth 8000 (kbps)
Last input 00:07:53, output 00:07:52, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
4 packets input, 404 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
13 packets output, 1284 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets



PE2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/32 is subnetted, 3 subnets
C 10.0.3.1 is directly connected, Loopback0
i L2 10.0.2.1 [115/20] via 192.168.1.5, FastEthernet1/0
i L2 10.0.1.1 [115/20] via 192.168.1.5, FastEthernet1/0
192.168.1.0/30 is subnetted, 2 subnets
i L2 192.168.1.0 [115/20] via 192.168.1.5, FastEthernet1/0
C 192.168.1.4 is directly connected, FastEthernet1/0
PE2#



CE2A#show ipv6 int bri
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C800:EFF:FEC8:1C
2001:1210:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C800:EFF:FEC8:0
FEC0:0:0:4::1
CE2A#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via 2001:1210:FFFF:1::1, FastEthernet1/0
via ::, FastEthernet1/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:4::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE2A#
CE2A#ping ipv6 FEC0:0:0:5::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
...!.
Success rate is 20 percent (1/5), round-trip min/avg/max = 420/420/420 ms
CE2A#

No comments:

Post a Comment