Sunday, July 12, 2009

Implenting L2 IPVPN with Interworking Frame Relay-Ethernet Using L2TPv3 LAB


Configuration Guidelines::
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.

Pseudo Wire-Class used CEA with Interworking Ethernet and Encapsulation l2tpv3
IGP used EIGRP in CE Domain
******************************************************************************
CE1A#sh running-config
ip cef
!
bridge irb
!
interface Loopback0
description <>
ip address 172.16.2.1 255.255.255.0
!
interface FastEthernet0/0
description <>
ip address 172.16.1.1 255.255.255.0
!
interface Serial0/0
description <>
no ip address
encapsulation frame-relay
clockrate 2000000
frame-relay lmi-type cisco
!
interface Serial0/0.101 point-to-point
frame-relay interface-dlci 101
bridge-group 1
!
interface BVI1
description <>
ip address 192.168.1.1 255.255.255.252
!
router eigrp 10
redistribute connected metric 1544 100 255 200 1500 route-map Only_Local
network 192.168.1.0 0.0.0.3
auto-summary
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet0/0
!

bridge 1 protocol ieee
bridge 1 route ip
!
CE1A#






PE1#sh running-config

ip cef
!
frame-relay switching
!
!
pseudowire-class CEA
encapsulation l2tpv3
interworking ethernet
ip local interface Loopback0
!

interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
!
interface Serial1/0
description <>
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay interface-dlci 101 switched
frame-relay lmi-type cisco
frame-relay intf-type dce
!
interface Serial1/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
serial restart-delay 0
isis circuit-type level-2-only
!
router isis
net 49.0001.0100.0000.1001.00
!
connect FR-ETH Serial1/0 101 l2transport
xconnect 10.0.3.1 1001 pw-class CEA
!

PE1#





P#sh running-config
ip cef
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial1/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
interface Serial1/1
description <>
ip address 192.168.1.9 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0002.0100.0000.3001.00

P#
PE2#sh running-config
ip cef
!
pseudowire-class CEA
encapsulation l2tpv3
interworking ethernet
ip local interface Loopback0
!

interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet1/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet1/0.101
encapsulation dot1Q 101
xconnect 10.0.1.1 1001 pw-class CEA
!
interface Serial2/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
serial restart-delay 0
isis circuit-type level-2-only
!
router isis
net 49.0003.0100.0000.2001.00
!

PE2#



CE2A#sh running-config
ip cef
!
interface Loopback0
description <>
ip address 172.16.3.1 255.255.255.0
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.101
encapsulation dot1Q 101
ip address 192.168.1.2 255.255.255.252
!

router eigrp 10
redistribute connected metric 1544 100 255 200 1500 route-map Only_Local
network 192.168.1.0 0.0.0.3
auto-summary
!

route-map Only_Local permit 10
match interface Loopback0
!
CE2A#







OUPUT VERIFICATION


PE1#sh l2tun

L2TP Tunnel and Session Information Total tunnels 1 sessions 1

LocID RemID Remote Name State Remote Address Port Sessions L2TP Class/
VPDN Group
27305 15861 PE2 est 10.0.3.1 0 1 l2tp_default_cl

LocID RemID TunID Username, Intf/ State Last Chg Uniq ID
Vcid, Circuit
41035 40228 27305 1001, Se1/0:101 est 00:19:58 4
PE1#show l2tun
PE1#show l2tun tun
PE1#show l2tun tunnel al
PE1#show l2tun tunnel all

L2TP Tunnel Information Total tunnels 1 sessions 1

Tunnel id 27305 is up, remote id is 15861, 1 active sessions
Locally initiated tunnel
Tunnel state is established, time since change 00:20:05
Tunnel transport is IP (L2TP) (115)
Remote tunnel name is PE2
Internet Address 10.0.3.1, port 0
Local tunnel name is PE1
Internet Address 10.0.1.1, port 0
L2TP class for tunnel is l2tp_default_class
Counters, taking last clear into account:
768 packets sent, 174 received
161852 bytes sent, 145245 received
Last clearing of counters never
Counters, ignoring last clear:
768 packets sent, 174 received
161852 bytes sent, 145245 received
Control Ns 40, Nr 38
Local RWS 32768 (default), Remote RWS 32768 (max)
Tunnel PMTU checking disabled
Retransmission time 1, max 1 seconds
Unsent queuesize 0, max 0
Resend queuesize 0, max 2
Total resends 0, ZLB ACKs sent 35
Total peer authentication failures 0
Current no session pak queue check 0 of 5
Retransmit time distribution: 0 0 0 0 0 0 0 0 0
Control message authentication is disabled
PE1#

PE1#show l2tun session packets

L2TP Session Information Total tunnels 1 sessions 1

LocID RemID TunID Pkts-In Pkts-Out Bytes-In Bytes-Out
41035 40228 27305 182 790 145837 162932
PE1#

PE2#show l2tun

L2TP Tunnel and Session Information Total tunnels 1 sessions 1

LocID RemID Remote Name State Remote Address Port Sessions L2TP Class/
VPDN Group
15861 27305 PE1 est 10.0.1.1 0 1 l2tp_default_cl

LocID RemID TunID Username, Intf/ State Last Chg Uniq ID
Vcid, Circuit
40228 41035 15861 1001, Fa1/0.101:101 est 00:20:21 4
PE2#show l2tun
PE2#show l2tun tun
PE2#show l2tun tunnel a
PE2#show l2tun tunnel all

L2TP Tunnel Information Total tunnels 1 sessions 1

Tunnel id 15861 is up, remote id is 27305, 1 active sessions
Remotely initiated tunnel
Tunnel state is established, time since change 00:20:27
Tunnel transport is IP (L2TP) (115)
Remote tunnel name is PE1
Internet Address 10.0.1.1, port 0
Local tunnel name is PE2
Internet Address 10.0.3.1, port 0
L2TP class for tunnel is l2tp_default_class
Counters, taking last clear into account:
179 packets sent, 784 received
147055 bytes sent, 162746 received
Last clearing of counters never
Counters, ignoring last clear:
179 packets sent, 784 received
147055 bytes sent, 162746 received
Control Ns 38, Nr 40
Local RWS 32768 (default), Remote RWS 32768 (max)
Tunnel PMTU checking disabled
Retransmission time 1, max 1 seconds
Unsent queuesize 0, max 0
Resend queuesize 0, max 2
Total resends 0, ZLB ACKs sent 34
Total peer authentication failures 0
Current no session pak queue check 0 of 5
Retransmit time distribution: 0 0 0 0 0 0 0 0 0
Control message authentication is disabled
PE2#show
PE2#show l2tun
PE2#show l2tun se
PE2#show l2tun session pa
PE2#show l2tun session packets

L2TP Session Information Total tunnels 1 sessions 1

LocID RemID TunID Pkts-In Pkts-Out Bytes-In Bytes-Out
40228 41035 15861 784 181 162528 147203
PE2#

CE1A#sh ip eigrp interfaces
IP-EIGRP interfaces for process 10

Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
BV1 1 0/0 236 0/15 50 0
CE1A#sh ip eig
CE1A#sh ip eigrp nei
CE1A#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.1.2 BV1 12 00:04:30 236 2124 0 4
CE1A#sh ip rou
CE1A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 3 subnets
C 172.16.1.0 is directly connected, FastEthernet0/0
C 172.16.2.0 is directly connected, Loopback0
D EX 172.16.3.0 [170/1811456] via 192.168.1.2, 00:04:12, BVI1
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, BVI1
CE1A#ping 172.16.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/135/236 ms
CE1A#

CE2A#sh ip eigrp interfaces
IP-EIGRP interfaces for process 10

Xmit Queue Mean Pacing Time Multicast Pending
Interface Peers Un/Reliable SRTT Un/Reliable Flow Timer Routes
Fa0/0.101 1 0/0 257 0/10 1052 0
CE2A#sh ip eig
CE2A#sh ip eigrp nei
CE2A#sh ip eigrp neighbors
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.1.1 Fa0/0.101 13 00:05:01 257 1542 0 2
CE2A#sh ip rou
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/24 is subnetted, 3 subnets
D EX 172.16.1.0
[170/1709056] via 192.168.1.1, 00:05:04, FastEthernet0/0.101
D EX 172.16.2.0
[170/1709056] via 192.168.1.1, 00:05:04, FastEthernet0/0.101
C 172.16.3.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0.101
CE2A#ping 172.16.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/112/156 ms
CE2A#

No comments:

Post a Comment