Monday, July 13, 2009

Implementing IPv6 Over MPLS 6PE with PE-CE BGP LAB


Configuration Guidelines::
PE-CE Routing Used "BGP"
IGP Used "ISIS" Level 2 between PE1 ,P1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
MP_iBGP established between PE1 & PE2 over Loopback Interface 10
********************************************************************************
CE1A#show running-config
ip cef
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:5::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::2/64
!
router bgp 64514
bgp router-id 172.16.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:810:FFFF:1::1 remote-as 64513
neighbor 2001:810:FFFF:1::1 description <>
!
address-family ipv6
neighbor 2001:810:FFFF:1::1 activate
neighbor 2001:810:FFFF:1::1 send-community extended
neighbor 2001:810:FFFF:1::1 soft-reconfiguration inbound
network 2001:810:FFFF:1::/64
no synchronization
exit-address-family
!

CE1A#











PE1#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ipv6 source-interface Loopback0
!
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::1/64
!
interface FastEthernet1/1
description <>
ip address 192.168.1.1 255.255.255.252
ip router isis
duplex full
speed 100
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.2222.3333.00
redistribute connected route-map Only_Local
redistribute static ip
!
router bgp 64513
bgp router-id 10.0.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.3.1 remote-as 64513
neighbor 10.0.3.1 description <>
neighbor 10.0.3.1 update-source Loopback0
neighbor 2001:810:FFFF:1::2 remote-as 64514
neighbor 2001:810:FFFF:1::2 description <>
!
address-family ipv6
neighbor 10.0.3.1 activate
neighbor 10.0.3.1 send-community extended
neighbor 10.0.3.1 soft-reconfiguration inbound
neighbor 10.0.3.1 send-label
neighbor 2001:810:FFFF:1::2 activate
neighbor 2001:810:FFFF:1::2 send-community extended
neighbor 2001:810:FFFF:1::2 soft-reconfiguration inbound
redistribute connected route-map Local
redistribute static
no synchronization
exit-address-family
!
no ip http server
no ip http secure-server
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/0
!
route-map Local permit 10
match interface FastEthernet1/0 FastEthernet1/1
!
mpls ldp router-id Loopback0
!

PE1#



P1#show running-config
ip cef
!
!
!
!
ipv6 unicast-routing
ipv6 cef
!
mpls ip
mpls label protocol ldp
mpls router-id loopback0
!
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1

!
interface FastEthernet1/0
description <>
duplex full
speed 100
ip address 192.168.1.2 255.255.255.252
mpls ip
mpls label protocol ldp
ip router isis
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
duplex full
speed 100
ip address 192.168.1.5 255.255.255.252
mpls ip
mpls label protocol ldp
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.1111.2222.00
!


P1#

PE2#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
mpls label protocol ldp
mpls ipv6 source-interface Loopback0
!
!
interface Loopback0
description <>
ip address 10.0.3.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet1/0
description <>
ip address 192.168.1.6 255.255.255.252
ip router isis
duplex full
speed 100
mpls label protocol ldp
mpls ip
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::1/64
!
router isis
net 49.0002.2222.1111.3333.00
!
router bgp 64513
bgp router-id 10.0.3.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
neighbor 2001:1210:FFFF:1::2 remote-as 64514
neighbor 2001:1210:FFFF:1::2 description <>
!
address-family ipv6
neighbor 10.0.1.1 activate
neighbor 10.0.1.1 send-community extended
neighbor 10.0.1.1 soft-reconfiguration inbound
neighbor 10.0.1.1 send-label
neighbor 2001:1210:FFFF:1::2 activate
neighbor 2001:1210:FFFF:1::2 send-community extended
neighbor 2001:1210:FFFF:1::2 soft-reconfiguration inbound
redistribute connected route-map Local
redistribute static
no synchronization
exit-address-family
!
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/1
!
route-map Local permit 10
match interface FastEthernet1/1
!
mpls ldp router-id Loopback0
!

PE2#




CE2A#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:4::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::2/64
!
router bgp 64514
bgp router-id 172.16.1.2
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 2001:1210:FFFF:1::1 remote-as 64513
neighbor 2001:1210:FFFF:1::1 description <>
!
address-family ipv6
neighbor 2001:1210:FFFF:1::1 activate
neighbor 2001:1210:FFFF:1::1 send-community extended
neighbor 2001:1210:FFFF:1::1 soft-reconfiguration inbound
network 2001:1210:FFFF:1::/64
no synchronization
exit-address-family
!

CE2A#



OUTPUT VERIFICATION

CE2A#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C800:EFF:FEC8:1C
2001:1210:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C800:EFF:FEC8:0
FEC0:0:0:4::1


CE2A#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via ::, FastEthernet1/0
via 2001:1210:FFFF:1::1, FastEthernet1/0
B 2001:810:FFFF:1::/64 [20/0]
via FE80::C804:9FF:FED4:1D, FastEthernet1/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:4::1/128 [0/0]
via ::, Loopback0
B FEC0:0:0:5::1/128 [20/0]
via FE80::C804:9FF:FED4:1D, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0

CE2A#show bgp ipv6 unicast summary
BGP router identifier 172.16.1.2, local AS number 64514
BGP table version is 5, main routing table version 5
4 network entries using 608 bytes of memory
5 path entries using 380 bytes of memory
4/3 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1540 total bytes of memory
BGP activity 5/1 prefixes, 6/1 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:1210:FFFF:1::1
4 64513 21 19 5 0 0 00:14:39 4
CE2A#show bgp ipv6 unicast lab
CE2A#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
2001:1210:FFFF:1::1
nolabel/nolabel
2001:1210:FFFF:1::/64
2001:1210:FFFF:1::1
nolabel/nolabel
:: nolabel/nolabel
FEC0:0:0:4::1/128
2001:1210:FFFF:1::1
nolabel/nolabel
FEC0:0:0:5::1/128
2001:1210:FFFF:1::1
nolabel/nolabel







CE2A#ping fec0:0:0:4::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:4::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/5/8 ms
CE2A#
CE2A#ping fec0:0:0:5::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 328/454/756 ms
CE2A#
PE2#show ipv6 int bri
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FastEthernet1/1 [up/up]
FE80::C804:9FF:FED4:1D
2001:1210:FFFF:1::1
Loopback0 [up/up]
PE2#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
B 2001:810:FFFF:1::/64 [200/0]
via ::FFFF:10.0.1.1, IPv6-mpls
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/1
L 2001:1210:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/1
S FEC0:0:0:4::1/128 [1/0]
via 2001:1210:FFFF:1::2, FastEthernet1/1
B FEC0:0:0:5::1/128 [200/0]
via ::FFFF:10.0.1.1, IPv6-mpls
L FF00::/8 [0/0]
via ::, Null0
PE2#show bgp ipv6 unicast summary
BGP router identifier 10.0.3.1, local AS number 64513
BGP table version is 9, main routing table version 9
4 network entries using 608 bytes of memory
5 path entries using 380 bytes of memory
4/2 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 2 (at peak 2) using 64 bytes of memory
BGP using 1572 total bytes of memory
BGP activity 6/2 prefixes, 7/2 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.1.1 4 64513 36 40 9 0 0 00:07:16 2
2001:1210:FFFF:1::2
4 64514 21 31 9 0 0 00:16:18 1
PE2#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
::FFFF:10.0.1.1 nolabel/20
2001:1210:FFFF:1::/64
2001:1210:FFFF:1::2
20/nolabel
:: 20/nolabel
FEC0:0:0:4::1/128
2001:1210:FFFF:1::2
19/nolabel
FEC0:0:0:5::1/128
::FFFF:10.0.1.1 nolabel/19

PE2#

P1#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
unassigned
FastEthernet1/1 [up/up]
Loopback0 [up/up]






P1#show ipv6 route
IPv6 Routing Table - 0 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
P1#

PE1#show ipv6 int bri
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C802:BFF:FE44:1C
2001:810:FFFF:1::1
FastEthernet1/1 [up/up]
Loopback0 [up/up]
PE1#show ipv6 route
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/0
B 2001:1210:FFFF:1::/64 [200/0]
via ::FFFF:10.0.3.1, IPv6-mpls
B FEC0:0:0:4::1/128 [200/0]
via ::FFFF:10.0.3.1, IPv6-mpls
S FEC0:0:0:5::1/128 [1/0]
via 2001:810:FFFF:1::2, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0
PE1#show bgp ipv6 unicast summary
BGP router identifier 10.0.1.1, local AS number 64513
BGP table version is 9, main routing table version 9
4 network entries using 608 bytes of memory
5 path entries using 380 bytes of memory
4/2 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 2 (at peak 2) using 64 bytes of memory
BGP using 1572 total bytes of memory
BGP activity 6/2 prefixes, 7/2 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.3.1 4 64513 37 41 9 0 0 00:08:26 2
2001:810:FFFF:1::2
4 64514 19 22 9 0 0 00:14:38 1
PE1#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
2001:810:FFFF:1::2
20/nolabel
:: 20/nolabel
2001:1210:FFFF:1::/64
::FFFF:10.0.3.1 nolabel/20
FEC0:0:0:4::1/128
::FFFF:10.0.3.1 nolabel/19
FEC0:0:0:5::1/128
2001:810:FFFF:1::2
19/nolabel

PE1#

CE1A#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C801:BFF:FE44:1C
2001:810:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C801:BFF:FE44:0
FEC0:0:0:5::1
CE1A#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via ::, FastEthernet1/0
via 2001:810:FFFF:1::1, FastEthernet1/0
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
B 2001:1210:FFFF:1::/64 [20/0]
via FE80::C802:BFF:FE44:1C, FastEthernet1/0
B FEC0:0:0:4::1/128 [20/0]
via FE80::C802:BFF:FE44:1C, FastEthernet1/0
LC FEC0:0:0:5::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE1A#show bgp ipv6 unicast summary
BGP router identifier 172.16.1.1, local AS number 64514
BGP table version is 5, main routing table version 5
4 network entries using 608 bytes of memory
5 path entries using 380 bytes of memory
4/3 BGP path/bestpath attribute entries using 496 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 1540 total bytes of memory
BGP activity 5/1 prefixes, 6/1 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
2001:810:FFFF:1::1
4 64513 22 20 5 0 0 00:15:19 4
CE1A#show bgp ipv6 unicast labels
Network Next Hop In label/Out label
2001:810:FFFF:1::/64
2001:810:FFFF:1::1
nolabel/nolabel
:: nolabel/nolabel
2001:1210:FFFF:1::/64
2001:810:FFFF:1::1
nolabel/nolabel
FEC0:0:0:4::1/128
2001:810:FFFF:1::1
nolabel/nolabel
FEC0:0:0:5::1/128
2001:810:FFFF:1::1
nolabel/nolabel

CE1A#ping fec0:0:0:5::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/3/8 ms
CE1A#ping fec0:0:0:4::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:4::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 248/322/424 ms
CE1A#

No comments:

Post a Comment