Saturday, July 4, 2009

Implementing L3 IPVPN using VRF-Lite LAB


Configuration Guidelines::

VRF Used "CEA"
RD Used "64513:100"
RT Used "64513:100"
AS Used "64513"
PE-CE Routing Used "OSPF"
IGP Used "ISIS" Level 2 between PE1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area
MP-iBGP set up between Tunnel100 interfaces on the PE1 & PE2

CE1A Config
**************************
!
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
description <>
ip address 192.168.1.1 255.255.255.252
!
router ospf 10
network 10.0.1.0 0.0.0.255 area 0
network 192.168.1.0 0.0.0.3 area 0
!

**********************************************************************PE1 Config
**************************
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
interface Tunnel100
ip vrf forwarding CEA
ip address 172.16.4.2 255.255.255.252
tunnel source Loopback1
tunnel destination 172.16.2.1
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Loopback1
ip address 172.16.1.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <>
ip vrf forwarding CEA
ip address 192.168.1.2 255.255.255.252
!
interface Serial0/1
description <>
ip address 192.168.1.5 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
router ospf 10 vrf CEA
redistribute connected subnets
redistribute bgp 64513 subnets
network 192.168.1.0 0.0.0.3 area 0
!
router isis
net 49.0001.1111.2222.3333.00
!
router bgp 64513
no synchronization
neighbor 172.16.4.1 remote-as 64513
neighbor 172.16.4.1 update-source Tunnel100
no auto-summary
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA metric 2 match internal external 1 external 2
neighbor 172.16.4.1 remote-as 64513
neighbor 172.16.4.1 activate
neighbor 172.16.4.1 send-community extended
no auto-summary
no synchronization
exit-address-family
!

**********************************************************************P Config
**************************
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <

>
ip address 192.168.1.6 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
interface Serial0/1
description <

>
ip address 192.168.1.9 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.1111.2222.00
!


**********************************************************************PE2 Config
**************************
!
ip vrf CEA
description <>
rd 64513:1
route-target export 64513:100
route-target import 64513:100
!
interface Tunnel100
ip vrf forwarding CEA
ip address 172.16.4.1 255.255.255.252
tunnel source Loopback1
tunnel destination 172.16.1.1
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface Loopback1
ip address 172.16.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface Serial0/0
description <>
ip address 192.168.1.10 255.255.255.252
ip router isis
isis circuit-type level-2-only
!
interface Serial0/1
description <>
ip vrf forwarding CEA
ip address 192.168.1.13 255.255.255.252
!
router ospf 10 vrf CEA
redistribute connected subnets
redistribute bgp 64513 subnets
network 192.168.1.12 0.0.0.3 area 0
!
router isis
net 49.0002.2222.3333.1111.00
!
router bgp 64513
no synchronization
neighbor 172.16.4.2 remote-as 64513
neighbor 172.16.4.2 update-source Tunnel100
neighbor 172.16.4.2 soft-reconfiguration inbound
no auto-summary
!
address-family ipv4 vrf CEA
redistribute connected
redistribute ospf 10 vrf CEA metric 2 match internal external 1 external 2
neighbor 172.16.4.2 remote-as 64513
neighbor 172.16.4.2 activate
neighbor 172.16.4.2 send-community extended
no auto-summary
no synchronization
exit-address-family
!

**********************************************************************CE2A Config
**************************
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
description <>
ip address 192.168.1.14 255.255.255.252
!
router ospf 10
redistribute connected subnets route-map Only_Local
network 192.168.1.12 0.0.0.3 area 0
!


OUTPUT VERIFICATION
**************************

CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets
O E2 172.16.4.0 [110/20] via 192.168.1.2, 00:15:50, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.1.0 is directly connected, Loopback0
O E2 10.0.5.0 [110/2] via 192.168.1.2, 00:01:08, Serial0/0
192.168.1.0/30 is subnetted, 2 subnets
O E2 192.168.1.12 [110/1] via 192.168.1.2, 00:01:08, Serial0/0
C 192.168.1.0 is directly connected, Serial0/0
CE1A#

CE2A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets
O E2 172.16.4.0 [110/20] via 192.168.1.13, 00:16:30, Serial0/0
10.0.0.0/24 is subnetted, 2 subnets
O E2 10.0.1.0 [110/2] via 192.168.1.13, 00:01:02, Serial0/0
C 10.0.5.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, Serial0/0
O E2 192.168.1.0 [110/1] via 192.168.1.13, 00:01:02, Serial0/0
CE2A#

PE1#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets
C 172.16.4.0 is directly connected, Tunnel100
10.0.0.0/24 is subnetted, 2 subnets
O 10.0.1.0 [110/65] via 192.168.1.1, 00:58:41, Serial0/0
B 10.0.5.0 [200/2] via 172.16.4.1, 00:01:52
192.168.1.0/30 is subnetted, 2 subnets
B 192.168.1.12 [200/0] via 172.16.4.1, 00:01:52
C 192.168.1.0 is directly connected, Serial0/0
PE1#

PE2#sh ip route vrf CEA

Routing Table: CEA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.16.0.0/30 is subnetted, 1 subnets
C 172.16.4.0 is directly connected, Tunnel100
10.0.0.0/24 is subnetted, 2 subnets
B 10.0.1.0 [200/2] via 172.16.4.2, 00:02:23
O E2 10.0.5.0 [110/20] via 192.168.1.14, 00:26:42, Serial0/1
192.168.1.0/30 is subnetted, 2 subnets
C 192.168.1.12 is directly connected, Serial0/1
B 192.168.1.0 [200/0] via 172.16.4.2, 00:02:23
PE2#

PE1#sh ip bgp vpnv4 all
BGP table version is 15, local router ID is 10.0.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf CEA)
*> 10.0.1.0/24 192.168.1.1 2 32768 ?
*>i10.0.5.0/24 172.16.4.1 2 100 0 ?
* i172.16.4.0/30 172.16.4.1 0 100 0 ?
*> 0.0.0.0 0 32768 ?
*> 192.168.1.0/30 0.0.0.0 0 32768 ?
*>i192.168.1.12/30 172.16.4.1 0 100 0 ?
PE1#

PE2#sh ip bgp vpnv4 all
BGP table version is 13, local router ID is 172.16.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 64513:1 (default for vrf CEA)
*>i10.0.1.0/24 172.16.4.2 2 100 0 ?
*> 10.0.5.0/24 192.168.1.14 2 32768 ?
*> 172.16.4.0/30 0.0.0.0 0 32768 ?
* i 172.16.4.2 0 100 0 ?
*>i192.168.1.0/30 172.16.4.2 0 100 0 ?
*> 192.168.1.12/30 0.0.0.0 0 32768 ?
PE2#


CE1A#traceroute 10.0.5.1

Type escape sequence to abort.
Tracing the route to 10.0.5.1

1 192.168.1.2 80 msec 92 msec 100 msec
2 172.16.4.1 168 msec 120 msec 80 msec
3 192.168.1.14 164 msec 148 msec *
CE1A#


CE2A#traceroute 10.0.1.1

Type escape sequence to abort.
Tracing the route to 10.0.1.1

1 192.168.1.13 48 msec 32 msec 32 msec
2 172.16.4.2 72 msec 104 msec 68 msec
3 192.168.1.1 108 msec 52 msec *
CE2A#

No comments:

Post a Comment