Friday, July 3, 2009

Implementing AToM for Like Circuits using VLAN Ethernet Link




Configuration Guidelines::



IGP Used "ISIS" Level 2 between PE1 & PE2. Loopbacks in Level 1 and
PE1 & PE2 in different area.

ATM Backbone in Provider Network

End User Connected with to CE1A Router using Microsoft Loopback Adapter through the Cloud.

Psuedowire Class used CEA

VCID used 1001

IGP for CE Domain is BGP

VLAN Ethernet Link used between PE-CE

VLAN used 100
***********************************************************************
CE1A#sh running-config
hostname CE1A
!
logging rate-limit console 10 except errors
no logging console
interface Loopback0
description <>
ip address 10.0.1.1 255.255.255.0
!
interface FastEthernet0/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.101
encapsulation dot1Q 101
ip address 192.168.1.1 255.255.255.252
!
interface FastEthernet0/1
description <>
ip address 172.168.1.1 255.255.255.252
!
router bgp 64513
no synchronization
redistribute connected route-map Only_Local
neighbor 10.0.5.1 remote-as 64513
neighbor 10.0.5.1 description <>
neighbor 10.0.5.1 update-source Loopback0
neighbor 10.0.5.1 soft-reconfiguration inbound
neighbor 10.0.5.1 route-map OUT out
no auto-summary
!
ip prefix-list OUT seq 10 deny 10.0.1.0/24
ip prefix-list OUT seq 20 permit 0.0.0.0/0 le 32
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet0/1
!
route-map OUT permit 10
match ip address prefix-list OUT
!
ip route 10.0.5.0 255.255.255.0 192.168.1.2

CE1A#





PE1#sh running-config
hostname PE1
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
!
pseudowire-class CEA
encapsulation mpls
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet2/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet2/0.100
encapsulation dot1Q 101
xconnect 10.0.4.1 1001 encapsulation mpls
!
interface ATM3/0
description <>
no ip address
no snmp trap link-status
no atm ilmi-keepalive
!
interface ATM3/0.10 mpls
ip address 192.168.1.5 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.2222.3333.00
!
mpls ldp router-id Loopback0
!

PE1#












P#sh running-config
hostname P
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
!
interface Loopback0
description <

>
ip address 10.0.3.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface ATM1/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.10 mpls
ip address 192.168.1.6 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
isis circuit-type level-2-only
!
interface ATM2/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM2/0.20 mpls
ip address 192.168.1.9 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 4 32
isis circuit-type level-2-only
!
router isis
net 49.0002.2222.1111.3333.00
!
P#











PE2#sh running-config
hostname PE2
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
pseudowire-class CEA
encapsulation mpls
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface FastEthernet2/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet2/0.100
encapsulation dot1Q 101
xconnect 10.0.2.1 1001 encapsulation mpls
!
interface ATM3/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM3/0.20 mpls
ip address 192.168.1.10 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 4 32
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.2222.1111.00
!

PE2#














CE2A#sh running-config
hostname CE2A
!
interface Loopback0
description <>
ip address 10.0.5.1 255.255.255.0
!
interface FastEthernet0/0
description <>
!
interface FastEthernet0/0.101
encapsulation dot1Q 101
ip address 192.168.1.2 255.255.255.252
!
router bgp 64513
no synchronization
redistribute connected route-map Only_Local
neighbor 10.0.1.1 remote-as 64513
neighbor 10.0.1.1 description <>
neighbor 10.0.1.1 update-source Loopback0
neighbor 10.0.1.1 soft-reconfiguration inbound
no auto-summary
!
ip route 10.0.1.0 255.255.255.0 192.168.1.1
!
route-map Only_Local permit 10
match interface Loopback0

CE2A#
OUTPUT VERIFICATION
CE2A#show ip bgp summary
BGP router identifier 10.0.5.1, local AS number 64513
BGP table version is 7, main routing table version 7
2 network entries and 2 paths using 274 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 4/52 prefixes, 4/2 paths, scan interval 15 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.1.1 4 64513 24 18 7 0 0 00:13:15 1

CE2A#sh ip bgp
BGP table version is 7, local router ID is 10.0.5.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.5.0/24 0.0.0.0 0 32768 ?
*>i172.168.1.0/30 10.0.1.1 0 100 0 ?








CE2A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/30 is subnetted, 1 subnets
B 172.168.1.0 [200/0] via 10.0.1.1, 00:00:30
10.0.0.0/24 is subnetted, 2 subnets
S 10.0.1.0 [1/0] via 192.168.1.1
C 10.0.5.0 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0.101
CE2A#ping 172.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/145/288 ms
CE2A#




PE2#show mpls l2transport vc detail
Local interface: Fa2/0.100 up, line protocol up, Eth VLAN 101 up
Destination address: 10.0.2.1, VC ID: 1001, VC status: up
Next hop: point2point
Output interface: AT3/0.20, imposed label stack {1/33 16}
Create time: 00:36:00, last status change time: 00:35:20
Signaling protocol: LDP, peer 10.0.2.1:0 up
MPLS VC labels: local 19, remote 16
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 96, send 89
byte totals: receive 9597, send 9105
packet drops: receive 0, seq error 0, send 0

PE2#











PE1#show mpls l2transport vc detail
Local interface: Fa2/0.100 up, line protocol up, Eth VLAN 101 up
Destination address: 10.0.4.1, VC ID: 1001, VC status: up
Next hop: point2point
Output interface: AT3/0.10, imposed label stack {1/35 19}
Create time: 00:40:43, last status change time: 00:35:52
Signaling protocol: LDP, peer 10.0.4.1:0 up
MPLS VC labels: local 16, remote 19
Group ID: local 0, remote 0
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 89, send 96
byte totals: receive 9105, send 9597
packet drops: receive 0, seq error 0, send 0

PE1#












CE1A#show ip bgp summary
BGP router identifier 10.0.1.1, local AS number 64513
BGP table version is 6, main routing table version 6
3 network entries and 3 paths using 411 bytes of memory
2 BGP path attribute entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP activity 4/21 prefixes, 4/1 paths, scan interval 15 secs

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.5.1 4 64513 20 26 6 0 0 00:15:08 1
CE1A#sh ip bg
CE1A#sh ip bgp
BGP table version is 6, local router ID is 10.0.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
*> 10.0.1.0/24 0.0.0.0 0 32768 ?
*>i10.0.5.0/24 10.0.5.1 0 100 0 ?
*> 172.168.1.0/30 0.0.0.0 0 32768 ?







CE1A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/30 is subnetted, 1 subnets
C 172.168.1.0 is directly connected, FastEthernet0/1
10.0.0.0/24 is subnetted, 2 subnets
C 10.0.1.0 is directly connected, Loopback0
S 10.0.5.0 [1/0] via 192.168.1.2
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet0/0.101












CE1A#ping
Protocol [ip]:
Target IP address: 10.0.5.1
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 172.168.1.1
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 80/122/220 ms
CE1A#

No comments:

Post a Comment