Monday, July 13, 2009

Implementing IPv6 with BGP over ISIS LAB


Configuration Guidelines::
PE-CE Routing Used "Static"
IGP Used "ISIS" Level 2 between PE1 ,P1 & PE2 .Loopbacks in Level 1 and PE1 & PE2 in different area.
IBGP between loopbacks on PE1 & PE2
********************************************************************************


CE1A#sh running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:5::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::2/64
!
ipv6 route ::/0 FastEthernet1/0 2001:810:FFFF:1::1
ipv6 route ::/0 FastEthernet1/0
!
CE1A#


PE1#sh running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:9::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:810:FFFF:1::1/64
!
interface FastEthernet1/1
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:410:FFFF:1::1/64
ipv6 router isis
isis circuit-type level-2-only
!
router isis
net 49.0001.1111.2222.3333.00
!
address-family ipv6
redistribute connected route-map Only_Local
exit-address-family
!
router bgp 64513
bgp router-id 192.168.1.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor FEC0:0:0:7::1 remote-as 64513
neighbor FEC0:0:0:7::1 description <>
neighbor FEC0:0:0:7::1 update-source Loopback0
!
address-family ipv4
neighbor FEC0:0:0:7::1 activate
neighbor FEC0:0:0:7::1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor FEC0:0:0:7::1 activate
neighbor FEC0:0:0:7::1 send-community extended
neighbor FEC0:0:0:7::1 soft-reconfiguration inbound
redistribute static
no synchronization
exit-address-family
!
ipv6 route FEC0:0:0:5::1/128 FastEthernet1/0 2001:810:FFFF:1::2
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/0
!
PE1#






P1#sh running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:8::1/128
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:410:FFFF:1::2/64
ipv6 router isis
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
no ip address
duplex full
speed 100
ipv6 address 3FFE:B00:FFFF:1::1/64
ipv6 router isis
isis circuit-type level-2-only
!
router isis
net 49.0002.3333.1111.2222.00
!
P1#



PE2#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:7::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 3FFE:B00:FFFF:1::2/64
ipv6 router isis
isis circuit-type level-2-only
!
interface FastEthernet1/1
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::1/64
!
router isis
net 49.0002.2222.1111.3333.00
redistribute static ip
!
address-family ipv6
redistribute connected route-map Only_Local
exit-address-family
!
router bgp 64513
bgp router-id 192.168.1.3
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor FEC0:0:0:9::1 remote-as 64513
neighbor FEC0:0:0:9::1 description <>
neighbor FEC0:0:0:9::1 update-source Loopback0
!
address-family ipv4
neighbor FEC0:0:0:9::1 activate
neighbor FEC0:0:0:9::1 soft-reconfiguration inbound
no auto-summary
no synchronization
exit-address-family
!
address-family ipv6
neighbor FEC0:0:0:9::1 activate
neighbor FEC0:0:0:9::1 send-community extended
neighbor FEC0:0:0:9::1 soft-reconfiguration inbound
redistribute static
no synchronization
exit-address-family
!
ipv6 route FEC0:0:0:4::1/128 FastEthernet1/1 2001:1210:FFFF:1::2
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet1/1
PE2#



CE2A#show running-config
ip cef
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
description <>
no ip address
ipv6 address FEC0:0:0:4::1/128
!
interface FastEthernet1/0
description <>
no ip address
duplex full
speed 100
ipv6 address 2001:1210:FFFF:1::2/64
!
ipv6 route ::/0 FastEthernet1/0 2001:1210:FFFF:1::1
ipv6 route ::/0 FastEthernet1/0
!
CE2A#



OUTPUT VERFICIATION

CE2A#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C808:AFF:FE40:1C
2001:1210:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C808:AFF:FE40:0
FEC0:0:0:4::1

CE2A#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via ::, FastEthernet1/0
via 2001:1210:FFFF:1::1, FastEthernet1/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:1210:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:4::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE2A#ping
CE2A#ping 2001:810:FFFF:1::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:810:FFFF:1::2, timeout is 2 seconds:
!...!
Success rate is 40 percent (2/5), round-trip min/avg/max = 180/194/208 ms
CE2A#ping fec0:0:0:5::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:5::1, timeout is 2 seconds:
.U.U.
Success rate is 0 percent (0/5)
CE2A#

PE2#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C802:AFF:FE40:1C
3FFE:B00:FFFF:1::2
FastEthernet1/1 [up/up]
FE80::C802:AFF:FE40:1D
2001:1210:FFFF:1::1
Loopback0 [up/up]
FE80::C802:AFF:FE40:0
FEC0:0:0:7::1





PE2#show ip bgp summary
BGP router identifier 192.168.1.3, local AS number 64513
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
FEC0:0:0:9::1 4 64513 14 14 1 0 0 00:10:11 0
PE2#show ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
I2 2001:410:FFFF:1::/64 [115/20]
via FE80::C801:8FF:FE88:1D, FastEthernet1/0
I2 2001:810:FFFF:1::/64 [115/20]
via FE80::C801:8FF:FE88:1D, FastEthernet1/0
C 2001:1210:FFFF:1::/64 [0/0]
via ::, FastEthernet1/1
L 2001:1210:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/1
C 3FFE:B00:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
S FEC0:0:0:4::1/128 [1/0]
via 2001:1210:FFFF:1::2, FastEthernet1/1
B FEC0:0:0:5::1/128 [200/0]
via 2001:810:FFFF:1::2
LC FEC0:0:0:7::1/128 [0/0]
via ::, Loopback0
I2 FEC0:0:0:9::1/128 [115/20]
via FE80::C801:8FF:FE88:1D, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0
PE2#

P1#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C801:8FF:FE88:1C
2001:410:FFFF:1::2
FastEthernet1/1 [up/up]
FE80::C801:8FF:FE88:1D
3FFE:B00:FFFF:1::1
Loopback0 [up/up]
FE80::C801:8FF:FE88:0
FEC0:0:0:8::1
P1#sho
P1#show ipv
P1#show ipv6 rou
P1#show ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:410:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:410:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
I2 2001:810:FFFF:1::/64 [115/10]
via FE80::C800:8FF:FE88:1D, FastEthernet1/0
I2 2001:1210:FFFF:1::/64 [115/10]
via FE80::C802:AFF:FE40:1C, FastEthernet1/1
C 3FFE:B00:FFFF:1::/64 [0/0]
via ::, FastEthernet1/1
L 3FFE:B00:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/1
I2 FEC0:0:0:7::1/128 [115/10]
via FE80::C802:AFF:FE40:1C, FastEthernet1/1
LC FEC0:0:0:8::1/128 [0/0]
via ::, Loopback0
I2 FEC0:0:0:9::1/128 [115/10]
via FE80::C800:8FF:FE88:1D, FastEthernet1/0
L FF00::/8 [0/0]
via ::, Null0
P1#

PE1#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C800:8FF:FE88:1C
2001:810:FFFF:1::1
FastEthernet1/1 [up/up]
FE80::C800:8FF:FE88:1D
2001:410:FFFF:1::1
Loopback0 [up/up]
FE80::C800:8FF:FE88:0
FEC0:0:0:9::1

PE1#show ip bgp summary
BGP router identifier 192.168.1.1, local AS number 64513
BGP table version is 1, main routing table version 1

Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
FEC0:0:0:7::1 4 64513 15 15 1 0 0 00:11:02 0


PE1#show ipv6 route
IPv6 Routing Table - 11 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
C 2001:410:FFFF:1::/64 [0/0]
via ::, FastEthernet1/1
L 2001:410:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/1
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::1/128 [0/0]
via ::, FastEthernet1/0
I2 2001:1210:FFFF:1::/64 [115/20]
via FE80::C801:8FF:FE88:1C, FastEthernet1/1
I2 3FFE:B00:FFFF:1::/64 [115/20]
via FE80::C801:8FF:FE88:1C, FastEthernet1/1
B FEC0:0:0:4::1/128 [200/0]
via 2001:1210:FFFF:1::2
S FEC0:0:0:5::1/128 [1/0]
via 2001:810:FFFF:1::2, FastEthernet1/0
I2 FEC0:0:0:7::1/128 [115/20]
via FE80::C801:8FF:FE88:1C, FastEthernet1/1
LC FEC0:0:0:9::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
PE1#

CE1A#show ipv6 interface brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C807:5FF:FE88:1C
2001:810:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C807:5FF:FE88:0
FEC0:0:0:5::1
CE1A#
CE1A#sho
CE1A#show ipv
CE1A#show ipv6 int bri
CE1A#show ipv6 int brief
FastEthernet0/0 [administratively down/down]
FastEthernet1/0 [up/up]
FE80::C807:5FF:FE88:1C
2001:810:FFFF:1::2
FastEthernet1/1 [administratively down/down]
Loopback0 [up/up]
FE80::C807:5FF:FE88:0
FEC0:0:0:5::1
CE1A#sho
CE1A#show ipv
CE1A#show ipv6 rou
CE1A#show ipv6 route
IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
U - Per-user Static route, M - MIPv6
I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
D - EIGRP, EX - EIGRP external
S ::/0 [1/0]
via 2001:810:FFFF:1::1, FastEthernet1/0
via ::, FastEthernet1/0
C 2001:810:FFFF:1::/64 [0/0]
via ::, FastEthernet1/0
L 2001:810:FFFF:1::2/128 [0/0]
via ::, FastEthernet1/0
LC FEC0:0:0:5::1/128 [0/0]
via ::, Loopback0
L FF00::/8 [0/0]
via ::, Null0
CE1A#ping 2001:1210:ffff:1::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1210:FFFF:1::2, timeout is 2 seconds:
.!...
Success rate is 20 percent (1/5), round-trip min/avg/max = 272/272/272 ms
CE1A#ping fec0:0:0:4::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FEC0:0:0:4::1, timeout is 2 seconds:
U.U.U
Success rate is 0 percent (0/5)
CE1A#

No comments:

Post a Comment