Saturday, July 11, 2009

Implementing Interworking & Local Switching in MPLS Cell Mode L2 VPN with OSPF & ISIS in CE Domain


e>
ip address 172.168.5.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
description <>
ip address 172.168.3.3 255.255.255.248
encapsulation frame-relay
ip ospf priority 0
frame-relay interface-dlci 103
frame-relay lmi-type ansi
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.168.3.0 0.0.0.7 area 1
!
route-map Only_Local permit 10
match interface Loopback0

CE13A#
CE12A#sh running-config
frame-relay switching
!
interface Loopback0
description <>
ip address 172.168.4.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial0/0
description <>
ip address 172.168.3.2 255.255.255.248
encapsulation frame-relay
ip ospf priority 0
frame-relay interface-dlci 102
frame-relay lmi-type ansi
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
network 172.168.3.0 0.0.0.7 area 1
!
route-map Only_Local permit 10
match interface Loopback0

CE12A#
CE1A#sh running-config
ip cef
!
frame-relay switching
!
bridge irb
!
interface Loopback0
description <>
ip address 172.168.2.1 255.255.255.0
ip ospf network point-to-point
!
interface Serial1/0
description <>
no ip address
encapsulation frame-relay IETF
serial restart-delay 0
frame-relay lmi-type cisco
!
interface Serial1/0.401 point-to-point
frame-relay interface-dlci 401
bridge-group 1
!
interface Serial1/1
description <>
ip address 172.168.3.1 255.255.255.248
encapsulation frame-relay
ip split-horizon
serial restart-delay 0
frame-relay map ip 172.168.3.3 301 broadcast
frame-relay map ip 172.168.3.2 201 broadcast
frame-relay interface-dlci 201
frame-relay interface-dlci 301
frame-relay lmi-type ansi
!
interface Serial1/2
description <>
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
!
interface Serial1/2.501 point-to-point
frame-relay interface-dlci 501
bridge-group 2
!
interface FastEthernet2/0
description <>
ip address 172.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface BVI1
description <>
ip address 192.168.1.1 255.255.255.252
!
interface BVI2
ip address 192.168.2.1 255.255.255.252
!
router eigrp 10
redistribute connected metric 1544 100 255 200 1500 route-map Local
redistribute ospf 10 metric 1544 100 255 200 1500
network 192.168.2.0 0.0.0.3
auto-summary
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Local
redistribute eigrp 10 subnets
network 172.168.3.0 0.0.0.7 area 1
network 192.168.1.0 0.0.0.3 area 0
neighbor 172.168.3.2
neighbor 172.168.3.3
!
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet2/0
!
route-map Local permit 10
match interface BVI2 BVI1 Serial1/1
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
!
CE1A#













CE3A#sh running-config
ip cef
!
bridge irb
!
interface Loopback1
description <>
ip address 172.168.9.1 255.255.255.0
!
interface Serial1/0
description <>
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay lmi-type cisco
!
interface Serial1/0.601 point-to-point
frame-relay interface-dlci 601
bridge-group 2
!
interface BVI2
ip address 192.168.2.2 255.255.255.252
!
router eigrp 10
redistribute connected metric 1544 100 255 200 1500 route-map Only_Local
network 192.168.2.0 0.0.0.3
auto-summary
!
route-map Only_Local permit 10
match interface Loopback1 Serial1/0
!
bridge 2 protocol ieee
bridge 2 route ip
!

CE3A#














PE1#sh running-config
ip cef
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
frame-relay switching
!
!
pseudowire-class CEA
encapsulation mpls
interworking ethernet
!
interface Loopback0
description <>
ip address 10.0.2.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface ATM1/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.10 mpls
ip address 192.168.1.5 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
isis circuit-type level-2-only
!
interface Serial2/0
description <>
no ip address
encapsulation frame-relay IETF
no fair-queue
serial restart-delay 0
frame-relay interface-dlci 401 switched
frame-relay lmi-type cisco
frame-relay intf-type dce
!
interface Serial2/1
description <>
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay interface-dlci 501 switched
load-interval 30
frame-relay lmi-type cisco
frame-relay intf-type dce
!
interface Serial2/1.501 point-to-point
!
interface Serial2/3
description <>
no ip address
encapsulation frame-relay
serial restart-delay 0
frame-relay interface-dlci 601 switched
frame-relay lmi-type cisco
frame-relay intf-type dce
!
!
router isis
net 49.0001.0010.0020.0001.00
!
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
connect ETH-FR Serial2/0 401 l2transport
xconnect 10.0.4.1 1001 pw-class CEA
!
connect Local_Switching Serial2/1 501 Serial2/3 601
!
mpls ldp router-id Loopback0
!
PE1#



PE2#sh running-config
ip cef
!
mpls label protocol ldp
mpls ldp loop-detection
mpls ldp session protection
!
pseudowire-class CEA
encapsulation mpls
interworking ethernet
!
interface Loopback0
description <>
ip address 10.0.4.1 255.255.255.255
ip router isis
isis circuit-type level-1
!
interface ATM1/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.10 mpls
ip address 192.168.1.6 255.255.255.252
ip router isis
no snmp trap link-status
mpls label protocol ldp
mpls ip
mpls atm control-vc 2 32
isis circuit-type level-2-only
!
interface FastEthernet2/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet2/0.100
encapsulation dot1Q 100
xconnect 10.0.2.1 1001 pw-class CEA
!
router isis
net 49.0002.0010.0004.0001.00
!
mpls ldp router-id Loopback0
!

PE2#




CE2A#sh running-config
ip cef
!
!
interface Loopback0
description <>
ip address 172.168.8.1 255.255.255.0
ip router isis
isis circuit-type level-1
!
interface ATM1/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.30 point-to-point
ip address 172.168.7.1 255.255.255.252
ip router isis
no snmp trap link-status
isis circuit-type level-2-only
pvc 10/100
encapsulation aal5snap
!
!
interface FastEthernet2/0
description <>
no ip address
duplex auto
speed auto
!
interface FastEthernet2/0.100
encapsulation dot1Q 100
ip address 192.168.1.2 255.255.255.252
!
router ospf 10
log-adjacency-changes
redistribute connected subnets route-map Only_Local
redistribute isis level-2 subnets
network 192.168.1.0 0.0.0.3 area 0
!
router isis
net 49.0001.1721.6800.8001.00
redistribute connected route-map Only_Local
redistribute ospf 10
!
route-map Only_Local permit 10
match interface Loopback0 FastEthernet2/0.100 ATM1/0.30
!
CE2A#





CE21A#sh running-config
ip cef
!
interface Loopback0
description <>
ip address 172.168.6.1 255.255.255.0
ip router isis
isis circuit-type level-1
!

interface ATM1/0
description <>
no ip address
no atm ilmi-keepalive
!
interface ATM1/0.30 point-to-point
ip address 172.168.7.2 255.255.255.252
ip router isis
no snmp trap link-status
isis circuit-type level-2-only
pvc 20/100
encapsulation aal5snap
!
!
router isis
net 49.0002.1721.6800.6001.00
redistribute connected route-map Only_Local
!
!
route-map Only_Local permit 10
match interface Loopback0
!
CE21A#

OUTPUT VERIFICATION


CE21A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/16 is variably subnetted, 7 subnets, 3 masks
i L2 172.168.4.0/24 [115/10] via 172.168.7.1, ATM1/0.30
i L2 172.168.5.0/24 [115/10] via 172.168.7.1, ATM1/0.30
C 172.168.6.0/24 is directly connected, Loopback0
C 172.168.7.0/30 is directly connected, ATM1/0.30
i L2 172.168.3.0/29 [115/10] via 172.168.7.1, ATM1/0.30
i L2 172.168.8.0/24 [115/20] via 172.168.7.1, ATM1/0.30
i L2 172.168.9.0/24 [115/10] via 172.168.7.1, ATM1/0.30
192.168.1.0/30 is subnetted, 1 subnets
i L2 192.168.1.0 [115/10] via 172.168.7.1, ATM1/0.30
192.168.2.0/30 is subnetted, 1 subnets
i L2 192.168.2.0 [115/10] via 172.168.7.1, ATM1/0.30

CE21A#ping 172.168.9.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 440/612/824 ms
CE21A#
CE2A#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/16 is variably subnetted, 7 subnets, 3 masks
O E2 172.168.4.0/24 [110/20] via 192.168.1.1, 01:21:27, FastEthernet2/0.100
O E2 172.168.5.0/24 [110/20] via 192.168.1.1, 01:21:27, FastEthernet2/0.100
i L2 172.168.6.0/24 [115/20] via 172.168.7.2, ATM1/0.30
C 172.168.7.0/30 is directly connected, ATM1/0.30
O IA 172.168.3.0/29 [110/65] via 192.168.1.1, 01:23:52, FastEthernet2/0.100
C 172.168.8.0/24 is directly connected, Loopback0
O E2 172.168.9.0/24 [110/20] via 192.168.1.1, 00:23:31, FastEthernet2/0.100
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, FastEthernet2/0.100
192.168.2.0/30 is subnetted, 1 subnets
O E2 192.168.2.0 [110/20] via 192.168.1.1, 00:16:12, FastEthernet2/0.100

CE2A#ping 172.168.9.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 492/562/652 ms
CE2A#

PE1#show connection all

ID Name Segment 1 Segment 2 State
============================================================================================
1 ETH-FR Se2/0 401 10.0.4.1 1001 UP
2 Local_Switching Se2/1 501 Se2/3 601 UP

PE1#

PE2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not se

10.0.0.0/32 is subnetted, 2 subnets
i L2 10.0.2.1 [115/20] via 192.168.1.5, ATM1/0.10
C 10.0.4.1 is directly connected, Loopback0
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.4 is directly connected, ATM1/0.10
PE2#


CE3A#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.2.1 BV2 14 00:28:56 526 3156 0 11
CE3A#sho
CE3A#show ip rou
CE3A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/16 is variably subnetted, 7 subnets, 3 masks
D EX 172.168.4.0/24 [170/1811456] via 192.168.2.1, 00:31:58, BVI2
D EX 172.168.5.0/24 [170/1811456] via 192.168.2.1, 00:31:58, BVI2
D EX 172.168.6.0/24 [170/1811456] via 192.168.2.1, 00:31:58, BVI2
D EX 172.168.7.0/30 [170/1811456] via 192.168.2.1, 00:12:12, BVI2
D EX 172.168.3.0/29 [170/1811456] via 192.168.2.1, 00:00:05, BVI2
D EX 172.168.8.0/24 [170/1811456] via 192.168.2.1, 00:31:58, BVI2
C 172.168.9.0/24 is directly connected, Loopback1
192.168.1.0/30 is subnetted, 1 subnets
D EX 192.168.1.0 [170/1811456] via 192.168.2.1, 00:09:14, BVI2
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, BVI2

CE3A#ping 172.168.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 148/264/384 ms
CE3A#ping 172.168.4.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.4.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 276/315/364 ms
CE3A#
CE3A#CE3A#ping 172.168.6.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.6.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 608/682/868 ms
CE3A#ping 172.168.5.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.5.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 212/292/416 ms
CE3A#

CE1A#show ip eigrp neighbors
IP-EIGRP neighbors for process 10
H Address Interface Hold Uptime SRTT RTO Q Seq
(sec) (ms) Cnt Num
0 192.168.2.2 BV2 13 00:29:29 457 2742 0 12
CE1A#show ip osp
CE1A#show ip ospf nei
CE1A#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface
172.168.8.1 1 FULL/DR 00:00:30 192.168.1.2 BVI1
172.168.4.1 0 FULL/DROTHER 00:01:55 172.168.3.2 Serial1/1
172.168.5.1 0 FULL/DROTHER 00:01:34 172.168.3.3 Serial1/1
CE1A#show ip rou
CE1A#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/16 is variably subnetted, 9 subnets, 3 masks
O E2 172.168.4.0/24 [110/20] via 172.168.3.2, 01:24:06, Serial1/1
O E2 172.168.5.0/24 [110/20] via 172.168.3.3, 01:24:06, Serial1/1
O E2 172.168.6.0/24 [110/20] via 192.168.1.2, 01:24:06, BVI1
O E2 172.168.7.0/30 [110/20] via 192.168.1.2, 00:09:52, BVI1
C 172.168.1.0/24 is directly connected, FastEthernet2/0
C 172.168.2.0/24 is directly connected, Loopback0
C 172.168.3.0/29 is directly connected, Serial1/1
O E2 172.168.8.0/24 [110/20] via 192.168.1.2, 01:22:17, BVI1
D EX 172.168.9.0/24 [170/1811456] via 192.168.2.2, 00:26:05, BVI2
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, BVI1
192.168.2.0/30 is subnetted, 1 subnets
C 192.168.2.0 is directly connected, BVI2
CE1A#ping 172.168.9.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 268/315/364 ms
CE1A#
CE1A#

CE12A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/16 is variably subnetted, 7 subnets, 3 masks
C 172.168.4.0/24 is directly connected, Loopback0
O E2 172.168.5.0/24 [110/20] via 172.168.3.3, 01:29:26, Serial0/0
O E2 172.168.6.0/24 [110/20] via 172.168.3.1, 01:29:26, Serial0/0
O E2 172.168.7.0/30 [110/20] via 172.168.3.1, 00:15:28, Serial0/0
C 172.168.3.0/29 is directly connected, Serial0/0
O E2 172.168.8.0/24 [110/20] via 172.168.3.1, 01:27:47, Serial0/0
O E2 172.168.9.0/24 [110/20] via 172.168.3.1, 00:31:40, Serial0/0
192.168.1.0/30 is subnetted, 1 subnets
O IA 192.168.1.0 [110/128] via 172.168.3.1, 01:29:26, Serial0/0
192.168.2.0/30 is subnetted, 1 subnets
O E2 192.168.2.0 [110/20] via 172.168.3.1, 00:24:22, Serial0/0
CE12A#ping 172.168.9.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 204/276/444 ms
CE12A#
CE13A#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

172.168.0.0/16 is variably subnetted, 7 subnets, 3 masks
O E2 172.168.4.0/24 [110/20] via 172.168.3.2, 01:28:49, Serial0/0
C 172.168.5.0/24 is directly connected, Loopback0
O E2 172.168.6.0/24 [110/20] via 172.168.3.1, 01:28:49, Serial0/0
O E2 172.168.7.0/30 [110/20] via 172.168.3.1, 00:14:51, Serial0/0
C 172.168.3.0/29 is directly connected, Serial0/0
O E2 172.168.8.0/24 [110/20] via 172.168.3.1, 01:27:09, Serial0/0
O E2 172.168.9.0/24 [110/20] via 172.168.3.1, 00:31:03, Serial0/0
192.168.1.0/30 is subnetted, 1 subnets
O IA 192.168.1.0 [110/128] via 172.168.3.1, 01:28:49, Serial0/0
192.168.2.0/30 is subnetted, 1 subnets
O E2 192.168.2.0 [110/20] via 172.168.3.1, 00:23:45, Serial0/0
CE13A#ping 172.168.9.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.168.9.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 128/275/380 ms
CE13A#

No comments:

Post a Comment